grabfocus() don't work

Discuss OrbForms Designer and PocketC Architect

Postby Leif on Tue Sep 03, 2002 4:21 am

I can't get grabfocus() of a field to work.
I want a field to have focus when the form is entered, I tested with the grabfocus() call in the onOpen event (didn't work) then, for testing, I put the code in a button event, now the field shows the cursor but don't recive any data.
Tested it by taping anotheer field then the button, cursor moves but data entered will go into the first field, I tried to use relfocus() (for the field with focus) before calling grabfocus() same effect, tried setting inspt and also select(start,end) same result.

Is this a unsupported feature (i.e bug) or how is it supposed to work and where can I call it ( forms onOpen or )

Posts: 3
Joined: Fri Aug 16, 2002 9:57 am
Location: Sweden

Postby PenreeSoft on Tue Sep 03, 2002 12:16 pm

Hi Leif,
I too was unsuccessful getting this to recieve data. Putting it in the ondraw() got it to draw the cursor on form open but still it doesnt work.

Nicholas J. Penree
Nicholas J. Penree
Posts: 138
Joined: Sun May 26, 2002 8:14 pm
Location: USA

Postby dewey on Wed Sep 11, 2002 2:53 am

This is problem with the way grabfocus() is implemented in v1.1. This is fixed in 1.2, to be released in a week or two.
Site Admin
Posts: 749
Joined: Sun Oct 21, 2007 5:12 am

Return to OrbForms Designer and PocketC Architect

Who is online

Users browsing this forum: No registered users and 3 guests