include problems

Discuss PocketC for Palm OS (including Desktop Edition)

Postby Dude on Sun May 30, 2004 11:00 am

I have a Sony SJ20 running PocketC 6.5.1. I use Pedit as my menu pad editor & QED as my doc editor. I have the book "Palm Programming for the absolute beginner". I'm programming the Space Rescue Game. Since it is long, I'm writting it in QED. I'm calling the header files from Pedit 04. I've copied about 20 lines of code in QED. I wanted to check to be sure the header files were working, so I compiled it. The 2 header files are "/$event.h" & "/$ rescueLib.h". When I compile the code I get this error.

File: rescue.pc
Line: 3
unable to find

I find this strange because "event.h" loads fine. I went to PocketC website formum and tried every thing, but still no results. Can anyone help me.
Posts: 2
Joined: Sun May 30, 2004 10:53 am

Postby gmigueis on Wed Jun 02, 2004 3:43 am

Are you sure that the file name ends in .pc? (not the title - /$ ...), but the file name.
Posts: 18
Joined: Mon Mar 08, 2004 2:35 pm
Location: Portugal

Postby Dude on Wed Jun 09, 2004 6:56 am

In QED the file is saved as "rescue.pc". The first line of the file reads"//rescue". I read that the name the file is saved as and the first line of the file should be different. I don't think it matters(I would like someone to comment on this). Both include files are saved in (Pedit 04)in memopad format. I deleted the include statement for "rescueLib.h".Then I compiled it in PocketC. No error messages. I then reentered the include statement "rescueLib.h" and recompiled it. Now it works fine. I guess it was hung up and the above proceedure reset it.
Posts: 2
Joined: Sun May 30, 2004 10:53 am

Return to PocketC for Palm OS

Who is online

Users browsing this forum: No registered users and 4 guests