Page 1 of 1

PostPosted: Fri Oct 21, 2005 10:53 pm
by mackrackit

I am new to palm programing.Using Pocket C and Ccontrols.

When I run a program on the simulator, even Ccontrols example that I did not write bur compiled show this message:

error68k.c, Line:2092, ErrThrow called without a pending ErrTry

What am I doing wrong?

PostPosted: Thu Oct 27, 2005 3:11 am
by dewey
This is nothing that you are doing wrong, but I've never seen that error here. Can you get this repeatedly? Do you see any error when running on the emulator (which is much more useful for application debugging than the simulator)?

PostPosted: Thu Oct 27, 2005 11:14 pm
by mackrackit
Yes, I get this or error every time. When I compile a program with controls (buttons, dropdowns, etc)but have not written any code myself, I stil get errors but not always the same one. I did not log these other errors though.

As far as the emulator goes the program runs fine but will get errors if I run gremlins. I have a Zire72 and the compiled prc works fine with the code that I write.

I am only using the simulator as this is the recomendation from palm's website. When I program a microchip, it either works or I re-write. Is it critical to pass palm's test or just make the code work?

Thank you